aboutsummaryrefslogtreecommitdiff
path: root/contrib/depends/packages/packages.mk
diff options
context:
space:
mode:
authorTheCharlatan <seb.kung@gmail.com>2018-12-08 00:16:27 +0100
committerTheCharlatan <seb.kung@gmail.com>2019-01-17 13:23:24 +0100
commitb4433abc6452de45ec6f2b97971aeb0d5ee2bd7c (patch)
tree4a3330ff6bb4da4ad906cbd53403c2196c627879 /contrib/depends/packages/packages.mk
parentMerge pull request #5043 (diff)
downloadmonero-b4433abc6452de45ec6f2b97971aeb0d5ee2bd7c.tar.xz
Optimize the depends builds for faster compilation
This includes more fine grained configure options and skipping the openssl and zlib dependencies when compiling qt. The zlib and libevent packages are removed.
Diffstat (limited to 'contrib/depends/packages/packages.mk')
-rw-r--r--contrib/depends/packages/packages.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/contrib/depends/packages/packages.mk b/contrib/depends/packages/packages.mk
index b3a5992d0..4800c9936 100644
--- a/contrib/depends/packages/packages.mk
+++ b/contrib/depends/packages/packages.mk
@@ -1,4 +1,4 @@
-packages:=boost openssl libevent zeromq cppzmq zlib expat ldns cppzmq readline libiconv qt hidapi protobuf libusb
+packages:=boost openssl zeromq cppzmq expat ldns cppzmq readline libiconv qt hidapi protobuf libusb
native_packages := native_ccache native_protobuf
darwin_native_packages = native_biplist native_ds_store native_mac_alias
@@ -17,6 +17,5 @@ endif
ifneq ($(build_os),darwin)
darwin_native_packages += native_cctools native_cdrkit native_libdmg-hfsplus
-packages += readline
endif