aboutsummaryrefslogtreecommitdiff
path: root/contrib/depends/packages/packages.mk
diff options
context:
space:
mode:
authorTheCharlatan <seb.kung@gmail.com>2019-01-29 16:18:47 +0100
committerTheCharlatan <seb.kung@gmail.com>2019-02-23 15:34:59 +0100
commitf0fc4064a0c8d55d118cbef47a41b23cf998e194 (patch)
tree753b60c4233666006605a429a69839c3f4940d7b /contrib/depends/packages/packages.mk
parentMerge pull request #5062 (diff)
downloadmonero-f0fc4064a0c8d55d118cbef47a41b23cf998e194.tar.xz
Various speedups to depends and Travis
Further speedups to icu compilation, it is faster to run the pre-generated configure scripts. Ensure that the native protobuf installation only generates the required libraries and binaries. Disable qt compilation when running travis on windows. Qt is used for lrelease, the travis recipe instead usese the a local installation of lrelease. Remove various packages and options from the travis recipe. Update Readline to version 8.0. The previously used url 404'd sometimes, use the official gnu ftp server instead. Remove unused cmake config.
Diffstat (limited to 'contrib/depends/packages/packages.mk')
-rw-r--r--contrib/depends/packages/packages.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/contrib/depends/packages/packages.mk b/contrib/depends/packages/packages.mk
index 4800c9936..1db50580b 100644
--- a/contrib/depends/packages/packages.mk
+++ b/contrib/depends/packages/packages.mk
@@ -1,10 +1,11 @@
-packages:=boost openssl zeromq cppzmq expat ldns cppzmq readline libiconv qt hidapi protobuf libusb
+packages:=boost openssl zeromq cppzmq expat ldns cppzmq readline libiconv hidapi protobuf libusb
native_packages := native_ccache native_protobuf
darwin_native_packages = native_biplist native_ds_store native_mac_alias
darwin_packages = sodium-darwin
linux_packages = eudev
+qt_packages = qt
ifeq ($(host_os),linux)
packages += unwind