aboutsummaryrefslogtreecommitdiff
path: root/contrib/depends/packages/native_ccache.mk
diff options
context:
space:
mode:
authorTheCharlatan <seb.kung@gmail.com>2018-03-18 23:01:56 +0100
committerTheCharlatan <seb.kung@gmail.com>2018-09-10 22:03:42 +0200
commit0806a23a6e07834934fb2614bf27ee5d70bf2e2d (patch)
treed7ff9d1f2d892b63822018f711b2c22018303db9 /contrib/depends/packages/native_ccache.mk
parentMerge pull request #4290 (diff)
downloadmonero-0806a23a6e07834934fb2614bf27ee5d70bf2e2d.tar.xz
Initial depends addition
Depends cross compiles project dependencies for linux, mac and windows and multiple architectures. Depends is original work by Cory Fields and used in bitcoin and a wide range of bitcoin related projects.
Diffstat (limited to 'contrib/depends/packages/native_ccache.mk')
-rw-r--r--contrib/depends/packages/native_ccache.mk25
1 files changed, 25 insertions, 0 deletions
diff --git a/contrib/depends/packages/native_ccache.mk b/contrib/depends/packages/native_ccache.mk
new file mode 100644
index 000000000..4ed61a49e
--- /dev/null
+++ b/contrib/depends/packages/native_ccache.mk
@@ -0,0 +1,25 @@
+package=native_ccache
+$(package)_version=3.3.3
+$(package)_download_path=https://samba.org/ftp/ccache
+$(package)_file_name=ccache-$($(package)_version).tar.bz2
+$(package)_sha256_hash=2985bc5e32ebe38d2958d508eb54ddcad39eed909489c0c2988035214597ca54
+
+define $(package)_set_vars
+$(package)_config_opts=
+endef
+
+define $(package)_config_cmds
+ $($(package)_autoconf)
+endef
+
+define $(package)_build_cmds
+ $(MAKE)
+endef
+
+define $(package)_stage_cmds
+ $(MAKE) DESTDIR=$($(package)_staging_dir) install
+endef
+
+define $(package)_postprocess_cmds
+ rm -rf lib include
+endef