aboutsummaryrefslogtreecommitdiff
path: root/contrib/depends/packages/native_biplist.mk
diff options
context:
space:
mode:
authorTheCharlatan <seb.kung@gmail.com>2018-03-18 23:01:56 +0100
committerTheCharlatan <seb.kung@gmail.com>2018-09-10 22:03:42 +0200
commit0806a23a6e07834934fb2614bf27ee5d70bf2e2d (patch)
treed7ff9d1f2d892b63822018f711b2c22018303db9 /contrib/depends/packages/native_biplist.mk
parentMerge pull request #4290 (diff)
downloadmonero-0806a23a6e07834934fb2614bf27ee5d70bf2e2d.tar.xz
Initial depends addition
Depends cross compiles project dependencies for linux, mac and windows and multiple architectures. Depends is original work by Cory Fields and used in bitcoin and a wide range of bitcoin related projects.
Diffstat (limited to 'contrib/depends/packages/native_biplist.mk')
-rw-r--r--contrib/depends/packages/native_biplist.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/contrib/depends/packages/native_biplist.mk b/contrib/depends/packages/native_biplist.mk
new file mode 100644
index 000000000..3c6e8900f
--- /dev/null
+++ b/contrib/depends/packages/native_biplist.mk
@@ -0,0 +1,20 @@
+package=native_biplist
+$(package)_version=0.9
+$(package)_download_path=https://pypi.python.org/packages/source/b/biplist
+$(package)_file_name=biplist-$($(package)_version).tar.gz
+$(package)_sha256_hash=b57cadfd26e4754efdf89e9e37de87885f9b5c847b2615688ca04adfaf6ca604
+$(package)_install_libdir=$(build_prefix)/lib/python/dist-packages
+$(package)_patches=sorted_list.patch
+
+define $(package)_preprocess_cmds
+ patch -p1 < $($(package)_patch_dir)/sorted_list.patch
+endef
+
+define $(package)_build_cmds
+ python setup.py build
+endef
+
+define $(package)_stage_cmds
+ mkdir -p $($(package)_install_libdir) && \
+ python setup.py install --root=$($(package)_staging_dir) --prefix=$(build_prefix) --install-lib=$($(package)_install_libdir)
+endef