aboutsummaryrefslogtreecommitdiff
path: root/contrib/depends/packages/hidapi.mk
diff options
context:
space:
mode:
authorTheCharlatan <seb.kung@gmail.com>2018-09-22 20:07:33 +0200
committerTheCharlatan <seb.kung@gmail.com>2018-09-25 12:13:54 +0200
commit5c234cbdcbd7289539b2df4281ee20fbd12dbea0 (patch)
treeb8ef7ea806cdf8968182668d4f74864f18b9b5e5 /contrib/depends/packages/hidapi.mk
parentMerge pull request #4420 (diff)
downloadmonero-5c234cbdcbd7289539b2df4281ee20fbd12dbea0.tar.xz
Add hidapi to depends
Clang needs to get its cctools path passed directly for the hid build to succeed. Make gperf a permanent external dependency. Remove pcsc from depends.
Diffstat (limited to 'contrib/depends/packages/hidapi.mk')
-rw-r--r--contrib/depends/packages/hidapi.mk23
1 files changed, 23 insertions, 0 deletions
diff --git a/contrib/depends/packages/hidapi.mk b/contrib/depends/packages/hidapi.mk
new file mode 100644
index 000000000..b6b228643
--- /dev/null
+++ b/contrib/depends/packages/hidapi.mk
@@ -0,0 +1,23 @@
+package=hidapi
+$(package)_version=0.8.0-rc1
+$(package)_download_path=https://github.com/signal11/hidapi/archive
+$(package)_file_name=$(package)-$($(package)_version).tar.gz
+$(package)_sha256_hash=3c147200bf48a04c1e927cd81589c5ddceff61e6dac137a605f6ac9793f4af61
+
+define $(package)_set_vars
+$(package)_config_opts=--enable-static
+$(package)_config_opts+=--prefix=$(host_prefix)
+endef
+
+define $(package)_config_cmds
+ ./bootstrap &&\
+ $($(package)_autoconf) $($(package)_config_opts)
+endef
+
+define $(package)_build_cmds
+ $(MAKE)
+endef
+
+define $(package)_stage_cmds
+ $(MAKE) DESTDIR=$($(package)_staging_dir) install
+endef