aboutsummaryrefslogtreecommitdiff
path: root/contrib/depends/packages/cmake/test/CMakeLists.txt
diff options
context:
space:
mode:
authorTheCharlatan <seb.kung@gmail.com>2019-01-29 16:18:47 +0100
committerTheCharlatan <seb.kung@gmail.com>2019-02-23 15:34:59 +0100
commitf0fc4064a0c8d55d118cbef47a41b23cf998e194 (patch)
tree753b60c4233666006605a429a69839c3f4940d7b /contrib/depends/packages/cmake/test/CMakeLists.txt
parentMerge pull request #5062 (diff)
downloadmonero-f0fc4064a0c8d55d118cbef47a41b23cf998e194.tar.xz
Various speedups to depends and Travis
Further speedups to icu compilation, it is faster to run the pre-generated configure scripts. Ensure that the native protobuf installation only generates the required libraries and binaries. Disable qt compilation when running travis on windows. Qt is used for lrelease, the travis recipe instead usese the a local installation of lrelease. Remove various packages and options from the travis recipe. Update Readline to version 8.0. The previously used url 404'd sometimes, use the official gnu ftp server instead. Remove unused cmake config.
Diffstat (limited to 'contrib/depends/packages/cmake/test/CMakeLists.txt')
-rw-r--r--contrib/depends/packages/cmake/test/CMakeLists.txt18
1 files changed, 0 insertions, 18 deletions
diff --git a/contrib/depends/packages/cmake/test/CMakeLists.txt b/contrib/depends/packages/cmake/test/CMakeLists.txt
deleted file mode 100644
index 6075a8f5a..000000000
--- a/contrib/depends/packages/cmake/test/CMakeLists.txt
+++ /dev/null
@@ -1,18 +0,0 @@
-# This file is part of MXE. See LICENSE.md for licensing information.
-
-# 2.8.9 is Debian Wheezy version
-cmake_minimum_required(VERSION 2.8.9)
-
-# use default C and CXX languages
-project(mxe)
-
-# see cmake --help-policy <cmp> for details
-cmake_policy(SET CMP0017 NEW)
-if (POLICY CMP0020)
- cmake_policy(SET CMP0020 NEW)
-endif()
-
-# so we can find pkg-test.cmake files to include
-set(CMAKE_MODULE_PATH ${CMAKE_CURRENT_LIST_DIR}/../.. ${CMAKE_MODULE_PATH})
-
-include(${PKG}-test)