aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRiccardo Spagni <ric@spagni.net>2014-12-01 20:01:31 +0200
committerRiccardo Spagni <ric@spagni.net>2014-12-01 20:01:36 +0200
commit7935e49529dfe8139b8a5f34cb17700142319aa8 (patch)
tree305c92c2a251f0889ab1378a79dbb18e54f6685c /CMakeLists.txt
parentupdated readme to include libevent / libgtest deps (diff)
parentdon't build tests unless we're building all-* or *-test builds (diff)
downloadmonero-7935e49529dfe8139b8a5f34cb17700142319aa8.tar.xz
Merge pull request #191
685dd4a don't build tests unless we're building all-* or *-test builds (Riccardo Spagni)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ebca5c6fb..ee7bebdd9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -251,4 +251,7 @@ endif()
include(version.cmake)
add_subdirectory(src)
-add_subdirectory(tests)
+
+if(BUILD_TESTS)
+ add_subdirectory(tests)
+endif() \ No newline at end of file