aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTheCharlatan <seb.kung@gmail.com>2019-01-29 16:18:47 +0100
committerTheCharlatan <seb.kung@gmail.com>2019-02-23 15:34:59 +0100
commitf0fc4064a0c8d55d118cbef47a41b23cf998e194 (patch)
tree753b60c4233666006605a429a69839c3f4940d7b /CMakeLists.txt
parentMerge pull request #5062 (diff)
downloadmonero-f0fc4064a0c8d55d118cbef47a41b23cf998e194.tar.xz
Various speedups to depends and Travis
Further speedups to icu compilation, it is faster to run the pre-generated configure scripts. Ensure that the native protobuf installation only generates the required libraries and binaries. Disable qt compilation when running travis on windows. Qt is used for lrelease, the travis recipe instead usese the a local installation of lrelease. Remove various packages and options from the travis recipe. Update Readline to version 8.0. The previously used url 404'd sometimes, use the official gnu ftp server instead. Remove unused cmake config.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 31c3dbd21..f3f3e90a4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -898,7 +898,7 @@ if(MINGW)
set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -Wa,-mbig-obj")
set(EXTRA_LIBRARIES mswsock;ws2_32;iphlpapi;crypt32;bcrypt)
if(DEPENDS)
- set(ICU_LIBRARIES sicuio sicuin sicuuc sicudt sicutu iconv)
+ set(ICU_LIBRARIES icuio icui18n icuuc icudata icutu iconv)
else()
set(ICU_LIBRARIES icuio icuin icuuc icudt icutu iconv)
endif()