aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRiccardo Spagni <ric@spagni.net>2018-01-02 00:28:45 +0200
committerRiccardo Spagni <ric@spagni.net>2018-01-02 00:28:45 +0200
commitdd11bfb89c205a21a33329c87c754b7f60a5e4c7 (patch)
treef927193567d07a3ac5f3354cb75b096f8d37c807 /CMakeLists.txt
parentMerge pull request #2955 (diff)
parentEmbed the translation files in the binary (diff)
downloadmonero-dd11bfb89c205a21a33329c87c754b7f60a5e4c7.tar.xz
Merge pull request #2934
db2bc965 Embed the translation files in the binary (Guillaume LE VAILLANT)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 11c549d7c..4d451f8ad 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -365,6 +365,10 @@ endif()
add_definitions(-DAUTO_INITIALIZE_EASYLOGGINGPP)
+# Generate header for embedded translations
+add_subdirectory(translations)
+include_directories("${CMAKE_CURRENT_BINARY_DIR}/translations")
+
add_subdirectory(external)
# Final setup for miniupnpc