aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRiccardo Spagni <ric@spagni.net>2014-09-24 20:38:24 +0200
committerRiccardo Spagni <ric@spagni.net>2014-09-24 20:38:24 +0200
commitbff1f9d4c4c33a12349bc3e861fe4d387b749a74 (patch)
tree3ae09e3ee9e9371e050ecf5fa812b0ea0c743cb9 /CMakeLists.txt
parentfixed cmake folder (diff)
downloadmonero-bff1f9d4c4c33a12349bc3e861fe4d387b749a74.tar.xz
redo FindUnbound.cmake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c9a794c97..fcbd64ce4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -85,7 +85,9 @@ if (UNIX AND NOT APPLE)
find_package(Threads)
endif()
+# Find unbound - don't move this to the end, cmake is weird about this
find_package(Unbound REQUIRED)
+include_directories(${UNBOUND_INCLUDE})
if(MSVC)
add_definitions("/bigobj /MP /W3 /GS- /D_CRT_SECURE_NO_WARNINGS /wd4996 /wd4345 /D_WIN32_WINNT=0x0600 /DWIN32_LEAN_AND_MEAN /DGTEST_HAS_TR1_TUPLE=0 /FIinline_c.h /D__SSE4_1__")
@@ -210,5 +212,7 @@ else()
include_directories(${UPNP_INCLUDE})
endif()
+
+
add_subdirectory(src)
add_subdirectory(tests)