aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Boeckel <ben.boeckel@kitware.com>2014-10-21 14:20:26 -0400
committerBen Boeckel <ben.boeckel@kitware.com>2014-10-23 16:42:35 -0400
commit799e8b241fc4c049434c825a2a3d4f74d34d0ada (patch)
tree28af686c349e0b3362a4187699a79628ec34c60f /CMakeLists.txt
parentcmake: clean up if auto-dereferencing (diff)
downloadmonero-799e8b241fc4c049434c825a2a3d4f74d34d0ada.tar.xz
cmake: use option() for STATIC
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 35dd132ef..52835da84 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -90,7 +90,7 @@ if(MSVC OR MINGW)
else()
set(DEFAULT_STATIC false)
endif()
-set(STATIC ${DEFAULT_STATIC} CACHE BOOL "Link libraries statically")
+option(STATIC "Link libraries statically" ${DEFAULT_STATIC})
IF(STATIC)
IF(MSVC)