aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHoward Chu <hyc@symas.com>2017-10-29 14:51:51 +0000
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2017-11-14 17:06:37 +0000
commit0d9c0db99679e9372a1cd8a97cfef76a18096ab6 (patch)
tree7f3c5330b240962ceb09fdb0986fffcb1220cad3 /CMakeLists.txt
parentsplit off readline code into epee_readline (diff)
downloadmonero-0d9c0db99679e9372a1cd8a97cfef76a18096ab6.tar.xz
Do not build against epee_readline if it was not built
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index df0b22895..72afd5212 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -689,6 +689,7 @@ if(USE_READLINE)
add_definitions(-DHAVE_READLINE)
include_directories(${Readline_INCLUDE_DIR})
message(STATUS "Found readline library at: ${Readline_ROOT_DIR}")
+ set(EPEE_READLINE epee_readline)
else()
message(STATUS "Could not find GNU readline library so building without readline support")
endif()