aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRiccardo Spagni <ric@spagni.net>2015-07-16 12:48:55 +0200
committerRiccardo Spagni <ric@spagni.net>2015-07-16 12:49:29 +0200
commitdc624849bf602072fc91ea4182462b5660888c76 (patch)
tree44df6c7b56ca141e8348f0ff0586577e62820758 /CMakeLists.txt
parentMerge pull request #338 (diff)
parentfixed ARM arch test to prevent breaking on short arch strings (diff)
downloadmonero-dc624849bf602072fc91ea4182462b5660888c76.tar.xz
Merge pull request #339
54c785d fixed ARM arch test to prevent breaking on short arch strings (Riccardo Spagni) a4254a4 updated vl32 to current (Riccardo Spagni) e6ab2df updated in-source lmdb (Riccardo Spagni) ea08c76 open() flag O_DSYNC isn't on BSD, use O_SYNC (Thomas Winget)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt29
1 files changed, 17 insertions, 12 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9ec6d2c3a..9ccb4133e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -46,20 +46,25 @@ function (die msg)
endfunction ()
if (NOT ${ARCH} STREQUAL "")
- string(SUBSTRING ${ARCH} 0 5 ARM_TEST)
- string(TOLOWER ${ARM_TEST} ARM_TEST)
+ string(SUBSTRING ${ARCH} 0 3 IS_ARM)
+ string(TOLOWER ${IS_ARM} IS_ARM)
+
+ if (${IS_ARM} STREQUAL "arm")
+ string(SUBSTRING ${ARCH} 0 5 ARM_TEST)
+ string(TOLOWER ${ARM_TEST} ARM_TEST)
- if (${ARM_TEST} STREQUAL "armv6")
- set(ARM6 1)
- else()
- set(ARM6 0)
- endif()
+ if (${ARM_TEST} STREQUAL "armv6")
+ set(ARM6 1)
+ else()
+ set(ARM6 0)
+ endif()
- if (${ARM_TEST} STREQUAL "armv7")
- set(ARM7 1)
- else()
- set(ARM7 0)
- endif()
+ if (${ARM_TEST} STREQUAL "armv7")
+ set(ARM7 1)
+ else()
+ set(ARM7 0)
+ endif()
+ endif()
endif()
if(WIN32 OR ARM7 OR ARM6)