aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorluigi1111 <luigi1111w@gmail.com>2021-06-01 22:11:04 -0500
committerluigi1111 <luigi1111w@gmail.com>2021-06-01 22:11:04 -0500
commite8bf9003dd1270c9abf9fc81eb851baf9c4c6f34 (patch)
tree7afda9123f09dbf4bdd45600745b72c0f3a97671 /CMakeLists.txt
parentMerge pull request #7725 (diff)
parentCMake: add *.inl to monero_find_all_headers() glob, along *.h* (diff)
downloadmonero-e8bf9003dd1270c9abf9fc81eb851baf9c4c6f34.tar.xz
Merge pull request #7726
0f45211 CMake: add *.inl to monero_find_all_headers() glob, along *.h* (mj-xmr)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 23f680085..8cf8131a0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -168,11 +168,13 @@ endfunction()
#
# Parameters:
# - headers_found: Output variable, which will hold the found headers
-# - module_root_dir: The search path for the headers. Typically it will be the module's root dir.
+# - module_root_dir: The search path for the headers. Typically it will be the module's root dir, so "${CMAKE_CURRENT_SOURCE_DIR}" or a derivative of it.
macro (monero_find_all_headers headers_found module_root_dir)
file(GLOB ${headers_found}
"${module_root_dir}/*.h*" # h* will include hpps as well.
"${module_root_dir}/**/*.h*" # Any number of subdirs will be included.
+ "${module_root_dir}/*.inl" # .inl is typically template code and is being treated as headers (it's being included).
+ "${module_root_dir}/**/*.inl"
)
endmacro()