aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas Winget <tewinget@gmail.com>2015-04-07 16:13:42 -0400
committerThomas Winget <tewinget@gmail.com>2015-04-07 16:13:42 -0400
commit7292dea19222d1f6acba2fcee475d0726476d3fe (patch)
treed3e53f5b71fc1d8ac38566c36f50612b96e42b48 /CMakeLists.txt
parentOnly compile BerkeleyDB as an option in non-static (diff)
parentexplicitly disable AES on ARM (diff)
downloadmonero-7292dea19222d1f6acba2fcee475d0726476d3fe.tar.xz
Merges PR #37
New/updated Makefile targets
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2f0494396..7d731eb82 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -236,7 +236,15 @@ else()
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=c11 -D_GNU_SOURCE ${MINGW_FLAG} ${STATIC_ASSERT_FLAG} ${WARNINGS} ${C_WARNINGS} ${ARCH_FLAG} -maes")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -D_GNU_SOURCE ${MINGW_FLAG} ${WARNINGS} ${CXX_WARNINGS} ${ARCH_FLAG} -maes")
endif()
-
+
+ string(SUBSTRING ${ARCH} 0 3 ARM_TEST)
+ string(TOLOWER ${ARM_TEST} ARM_TEST)
+ if(${ARM_TEST} STREQUAL "arm")
+ message(STATUS "Setting ARM C and C++ flags")
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -mfpu=vfp -mfloat-abi=hard")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -mfpu=vfp -mfloat-abi=hard")
+ endif()
+
if(APPLE)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DGTEST_HAS_TR1_TUPLE=0")
endif()