aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMoroccanMalinois <MoroccanMalinois@protonmail.com>2018-08-21 23:22:33 +0000
committerMoroccanMalinois <MoroccanMalinois@protonmail.com>2018-08-21 23:22:33 +0000
commit620105ecaf74d2f5271403ce5d4ffd26fc9d9e85 (patch)
tree1e0541685a9aa875f343828acd828b30f555bf29 /CMakeLists.txt
parentMerge pull request #4191 (diff)
downloadmonero-620105ecaf74d2f5271403ce5d4ffd26fc9d9e85.tar.xz
Translations: handle cross compiling
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cab853581..0834e801b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -436,11 +436,7 @@ add_definition_if_function_found(strptime HAVE_STRPTIME)
add_definitions(-DAUTO_INITIALIZE_EASYLOGGINGPP)
# Generate header for embedded translations
-include(ExternalProject)
-ExternalProject_Add(generate_translations_header
- SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/translations"
- BINARY_DIR "${CMAKE_CURRENT_BINARY_DIR}/translations"
- INSTALL_COMMAND cmake -E echo "")
+add_subdirectory(translations)
include_directories("${CMAKE_CURRENT_BINARY_DIR}/translations")
add_subdirectory(external)