aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorZachary Michaels <mikezackles@gmail.com>2014-08-06 12:43:01 -0400
committerRiccardo Spagni <ric@spagni.net>2014-09-15 22:27:16 +0200
commit44f920b0fd9f8730473c690f63aebcc633d1a90f (patch)
tree4c108e8939a6a104b6e129c633fbb65423cd7162 /CMakeLists.txt
parentHack to allow toolchains to pass flags to mingw (diff)
downloadmonero-44f920b0fd9f8730473c690f63aebcc633d1a90f.tar.xz
Set the boost thread api for mingw
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dbbd097b9..cb06e7192 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -100,6 +100,7 @@ else()
if(MINGW)
set(WARNINGS "${WARNINGS} -Wno-error=unused-value -Wno-error=unused-but-set-variable")
set(MINGW_FLAG "${MINGW_FLAG} -DWIN32_LEAN_AND_MEAN")
+ set(Boost_THREADAPI win32)
include_directories(SYSTEM src/platform/mingw)
else()
set(MINGW_FLAG "")