aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTheCharlatan <seb.kung@gmail.com>2018-05-02 17:11:02 +0200
committerTheCharlatan <seb.kung@gmail.com>2018-09-10 22:08:05 +0200
commitf0ba19fde558b2ef8ac80132f163de3d0750869f (patch)
tree5ed3c42b3244f07ffb9289904bf27e9d2b654e3c /CMakeLists.txt
parentAdd Miniupnp submodule (diff)
downloadmonero-f0ba19fde558b2ef8ac80132f163de3d0750869f.tar.xz
Add lrelease to the depends
This includes a minimal qt build without gui
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 11 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 771b34949..59584a93e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -441,8 +441,18 @@ add_definitions(-DAUTO_INITIALIZE_EASYLOGGINGPP)
# Generate header for embedded translations
add_subdirectory(translations)
+#=======
+## Generate header for embedded translations, use target toolchain if depends, otherwise use the
+## lrelease and lupdate binaries from the host
+#include(ExternalProject)
+#ExternalProject_Add(generate_translations_header
+# SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/translations"
+# BINARY_DIR "${CMAKE_CURRENT_BINARY_DIR}/translations"
+# STAMP_DIR ${LRELEASE_PATH}
+# CMAKE_ARGS -DLRELEASE_PATH=${LRELEASE_PATH}
+# INSTALL_COMMAND cmake -E echo "")
+#>>>>>>> b1f43170... Add lrelease to the depends
include_directories("${CMAKE_CURRENT_BINARY_DIR}/translations")
-
add_subdirectory(external)
# Final setup for libunbound