aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorluigi1111 <luigi1111w@gmail.com>2022-01-24 15:14:08 -0500
committerluigi1111 <luigi1111w@gmail.com>2022-01-24 15:14:08 -0500
commitcb24b85bde9421fe5befb13f5f426be5fa2efc03 (patch)
treefbfd639d001f9d9440402006812726456f0410d6 /CMakeLists.txt
parentMerge pull request #8112 (diff)
parentFixed warnings for Clang (used as CMAKE_CXX compiler) (diff)
downloadmonero-cb24b85bde9421fe5befb13f5f426be5fa2efc03.tar.xz
Merge pull request #8116
6366187 Fixed warnings for Clang (used as CMAKE_CXX compiler) (SerHack)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5d510b853..20b356808 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -764,7 +764,7 @@ else()
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${ARCH_FLAG}")
set(WARNINGS "-Wall -Wextra -Wpointer-arith -Wundef -Wvla -Wwrite-strings -Wno-error=extra -Wno-error=deprecated-declarations -Wno-unused-parameter -Wno-error=unused-variable -Wno-error=undef -Wno-error=uninitialized")
- if(CMAKE_C_COMPILER_ID MATCHES "Clang")
+ if(CMAKE_C_COMPILER_ID MATCHES "Clang" OR CMAKE_CXX_COMPILER_ID MATCHES "Clang")
if(ARM)
set(WARNINGS "${WARNINGS} -Wno-error=inline-asm")
endif()