aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorluigi1111 <luigi1111w@gmail.com>2022-07-15 11:25:11 -0400
committerluigi1111 <luigi1111w@gmail.com>2022-07-15 11:25:11 -0400
commit9df069f4cefb20cc4dd172696a5c74888bd6d9d1 (patch)
treee1f04e62ac4c2281193cf30c421f5e092552284e /CMakeLists.txt
parentMerge pull request #8425 (diff)
parentaddress PR comments (diff)
downloadmonero-9df069f4cefb20cc4dd172696a5c74888bd6d9d1.tar.xz
Merge pull request #8426
a82fba4 address PR comments (j-berman) 3be1dbd connection: fix implementation (anon) 724ff21 connection: add segfault and deadlocks demo (anon)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3abd0722a..b05c087cf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1076,6 +1076,7 @@ if(STATIC)
set(Boost_USE_STATIC_RUNTIME ON)
endif()
find_package(Boost 1.58 QUIET REQUIRED COMPONENTS system filesystem thread date_time chrono regex serialization program_options locale)
+add_definitions(-DBOOST_ASIO_ENABLE_SEQUENTIAL_STRAND_ALLOCATION)
set(CMAKE_FIND_LIBRARY_SUFFIXES ${OLD_LIB_SUFFIXES})
if(NOT Boost_FOUND)