aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2018-10-20 21:36:51 +0000
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2018-10-20 21:37:40 +0000
commit7d21c9b5738e8d3cb1b021ce8b5be88ee1e07e85 (patch)
tree901f1ecf3343570b9f6cd9aaa1688d800f1e7796 /CMakeLists.txt
parentMerge pull request #4610 (diff)
downloadmonero-7d21c9b5738e8d3cb1b021ce8b5be88ee1e07e85.tar.xz
CMakeLists.txt: only use libatomic when found
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8baac02e9..a9fd6fd45 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -937,7 +937,9 @@ if(ANDROID)
endif()
if(CMAKE_C_COMPILER_ID STREQUAL "Clang" AND ARCH_WIDTH EQUAL "32" AND NOT IOS AND NOT FREEBSD)
find_library(ATOMIC atomic)
- list(APPEND EXTRA_LIBRARIES ${ATOMIC})
+ if (ATOMIC_FOUND)
+ list(APPEND EXTRA_LIBRARIES ${ATOMIC})
+ endif()
endif()
find_path(ZMQ_INCLUDE_PATH zmq.hpp)