aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2017-02-18 16:30:29 +0000
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2017-02-20 22:58:16 +0000
commitf640512c53caca9d7c3c69802841d174818cf953 (patch)
treeda53dbc70ea82562ac09dd4d7b414c3924c8f7db /CMakeLists.txt
parentcore: display any fork warning at startup too (diff)
downloadmonero-f640512c53caca9d7c3c69802841d174818cf953.tar.xz
Optionally query moneropulse DNS records to check for updates
It just checks and prints a message if there is a new version for now.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f59493345..c01be24d4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -88,6 +88,14 @@ else()
set(OPT_FLAGS_RELEASE "-Ofast")
endif()
+# BUILD_TAG is used to select the build type to check for a new version
+if(BUILD_TAG)
+ message(STATUS "Building build tag ${BUILD_TAG}")
+ add_definitions("-DBUILD_TAG=${BUILD_TAG}")
+else()
+ message(STATUS "Building without build tag")
+endif()
+
set(CMAKE_C_FLAGS_RELEASE "-DNDEBUG ${OPT_FLAGS_RELEASE}")
set(CMAKE_CXX_FLAGS_RELEASE "-DNDEBUG ${OPT_FLAGS_RELEASE}")