aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorhyc <hyc@symas.com>2017-04-12 23:54:33 +0100
committerhyc <hyc@symas.com>2017-04-12 23:54:33 +0100
commite65d66fe0449c8eeb0705d2531c109767d31fff0 (patch)
tree4ab85c6ac5b1635ceb12f87fdc153061e7afad85 /CMakeLists.txt
parentClean up ARMv8-a aes_expand_key() (diff)
downloadmonero-e65d66fe0449c8eeb0705d2531c109767d31fff0.tar.xz
Fix ARM64 identification
The actual arch flag the compiler recognizes is "armv8-a". This is true for both gcc and clang.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ceebd49ef..d584e41c0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -80,9 +80,10 @@ if (ARM_TEST STREQUAL "arm")
endif()
endif()
-if (ARM_ID STREQUAL "aarch64" OR ARM_ID STREQUAL "arm64")
+if (ARM_ID STREQUAL "aarch64" OR ARM_ID STREQUAL "arm64" OR ARM_ID STREQUAL "armv8-a")
set(ARM 1)
set(ARM8 1)
+ set(ARCH "armv8-a")
endif()
if(WIN32 OR ARM)