aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNanoAkron <nanoakron@users.noreply.github.com>2016-09-18 22:56:38 +0100
committerNanoAkron <nanoakron@users.noreply.github.com>2016-09-18 22:56:38 +0100
commitb8fb9d19194785ccaef830089d8553dc398d36db (patch)
treeb421fa059c9e77f3f6702ec7a2c8b38f49f19e38 /CMakeLists.txt
parentMerge pull request #1099 (diff)
downloadmonero-b8fb9d19194785ccaef830089d8553dc398d36db.tar.xz
Fix test for 'ARM_ID' as caught by @radfish in #1088
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9f15c73dc..b65c4ada3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -65,10 +65,10 @@ else()
set(ARCH_ID "${ARCH}")
endif()
string(TOLOWER "${ARCH_ID}" ARM_ID)
-string(SUBSTRING "${ARCH_ID}" 0 3 ARM_TEST)
+string(SUBSTRING "${ARM_ID}" 0 3 ARM_TEST)
if (ARM_TEST STREQUAL "arm")
set(ARM 1)
- string(SUBSTRING "${ARCH_ID}" 0 5 ARM_TEST)
+ string(SUBSTRING "${ARM_ID}" 0 5 ARM_TEST)
if (ARM_TEST STREQUAL "armv6")
set(ARM6 1)
endif()
@@ -77,7 +77,7 @@ if (ARM_TEST STREQUAL "arm")
endif()
endif()
-if (ARCH_ID STREQUAL "aarch64")
+if (ARM_ID STREQUAL "aarch64")
set(ARM 1)
set(ARM8 1)
endif()