aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorredfish <redfish@galactica.pw>2016-09-16 23:59:46 -0400
committerredfish <redfish@galactica.pw>2016-09-17 00:04:08 -0400
commitaa9a64556d32c9f6fafffb40a9cf4234e59b2d58 (patch)
treed24dfbba6566a84ea26625b1f6dec4a39dddddcf /CMakeLists.txt
parentMerge pull request #1077 (diff)
downloadmonero-aa9a64556d32c9f6fafffb40a9cf4234e59b2d58.tar.xz
cmake: remove redundant checks around CMAKE_{AR,RANLIB}
Those are always set, no point in checking. #1065
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 4 insertions, 10 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1f6c9f8d0..0c813b867 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -497,17 +497,11 @@ else()
endif()
# Since gcc 4.9 the LTO format is non-standard (slim), so we need the gcc-specific ar and ranlib binaries
if(CMAKE_CXX_COMPILER_ID STREQUAL "GNU" AND NOT (CMAKE_CXX_COMPILER_VERSION VERSION_LESS 4.9.0) AND NOT OPENBSD)
- # When invoking cmake on distributions on which gcc's binaries are prefix
- # with an arch-specific triplet, the user has to either specify
- # -DCHOST=... or -DCMAKE_AR=... and -DCMAKE_RANLIB=...
+ # When invoking cmake on distributions on which gcc's binaries are prefixed
+ # with an arch-specific triplet, the user must specify -DCHOST=<prefix>
if (DEFINED CHOST)
- set(CHOST_PREFIX "${CHOST}-")
- if (NOT DEFINED CMAKE_AR)
- set(CMAKE_AR "${CHOST_PREFIX}gcc-ar")
- endif()
- if (NOT DEFINED CMAKE_RANLIB)
- set(CMAKE_RANLIB "${CHOST_PREFIX}gcc-ranlib")
- endif()
+ set(CMAKE_AR "${CHOST}-gcc-ar")
+ set(CMAKE_RANLIB "${CHOST}-gcc-ranlib")
else()
set(CMAKE_AR "gcc-ar")
set(CMAKE_RANLIB "gcc-ranlib")