aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorluigi1111 <luigi1111w@gmail.com>2020-06-19 10:17:51 -0500
committerluigi1111 <luigi1111w@gmail.com>2020-06-19 10:17:51 -0500
commit93257997bd69e25c76de8ebf3f46bfeb44f11589 (patch)
tree1b9cf72c5a4911ca7ba449353a080be431a17c45 /CMakeLists.txt
parentMerge pull request #6637 (diff)
parentfuzz_tests: fix init check in oss-fuzz mode (diff)
downloadmonero-93257997bd69e25c76de8ebf3f46bfeb44f11589.tar.xz
Merge pull request #6656
bde7f1c fuzz_tests: fix init check in oss-fuzz mode (moneromooo-monero) c4b7420 Do not use PIE with OSS-Fuzz (moneromooo-monero) c4df8b1 fix leaks in fuzz tests (moneromooo-monero) 38ca1bb fuzz_tests: add a tx extra fuzz test (moneromooo-monero)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4fcf782aa..45a6aa1b5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -652,7 +652,7 @@ else()
endif()
# linker
- if (NOT SANITIZE AND NOT (WIN32 AND (CMAKE_C_COMPILER_ID STREQUAL "GNU" AND CMAKE_C_COMPILER_VERSION VERSION_LESS 9.1)))
+ if (NOT SANITIZE AND NOT OSSFUZZ AND NOT (WIN32 AND (CMAKE_C_COMPILER_ID STREQUAL "GNU" AND CMAKE_C_COMPILER_VERSION VERSION_LESS 9.1)))
# PIE executables randomly crash at startup with ASAN
# Windows binaries die on startup with PIE when compiled with GCC <9.x
add_linker_flag_if_supported(-pie LD_SECURITY_FLAGS)