aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2021-07-31 19:22:57 +0000
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2021-07-31 19:22:57 +0000
commit90d6bed8044ab583e86cc8bc8f237ad161f3dedf (patch)
treec9b5d1839fad17dfa83cc659e53ce5faa1ac85b2 /CMakeLists.txt
parentMerge pull request #7814 (diff)
downloadmonero-90d6bed8044ab583e86cc8bc8f237ad161f3dedf.tar.xz
cmake: bodge cmake failure on OSS-Fuzz
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 33b00a725..e3e31767d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -234,7 +234,7 @@ add_library(l3 OBJECT incorrect_source.cpp)
file(REMOVE_RECURSE "${TEST_PROJECT}")
endforeach()
endfunction()
-if (NOT (CMAKE_SYSTEM_NAME MATCHES "kOpenBSD.*|OpenBSD.*"))
+if (NOT (CMAKE_SYSTEM_NAME MATCHES "kOpenBSD.*|OpenBSD.*") AND NOT OSSFUZZ)
forbid_undefined_symbols()
endif()