aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2017-10-20 21:33:07 +0100
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2017-10-21 08:39:52 +0100
commit6a90506a8dafc163e08b732f86c8013418d63c7c (patch)
tree53dd9f1f01671c7aeed6c855933cc06c15168f73 /CMakeLists.txt
parentMerge pull request #2601 (diff)
downloadmonero-6a90506a8dafc163e08b732f86c8013418d63c7c.tar.xz
Link against libpgm/libnorm if found, optional libzmq ldependencies
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3eddfca0e..c2b5d966f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -702,6 +702,8 @@ include(version.cmake)
find_path(ZMQ_INCLUDE_PATH zmq.hpp)
find_library(ZMQ_LIB zmq)
+find_library(PGM_LIBRARY pgm)
+find_library(NORM_LIBRARY norm)
find_library(SODIUM_LIBRARY sodium)
if(NOT ZMQ_INCLUDE_PATH)
@@ -710,6 +712,12 @@ endif()
if(NOT ZMQ_LIB)
message(FATAL_ERROR "Could not find required libzmq")
endif()
+if(PGM_LIBRARY)
+ set(ZMQ_LIB "${ZMQ_LIB};${PGM_LIBRARY}")
+endif()
+if(NORM_LIBRARY)
+ set(ZMQ_LIB "${ZMQ_LIB};${NORM_LIBRARY}")
+endif()
if(SODIUM_LIBRARY)
set(ZMQ_LIB "${ZMQ_LIB};${SODIUM_LIBRARY}")
endif()