aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas Winget <tewinget@gmail.com>2015-03-25 05:56:36 -0400
committerThomas Winget <tewinget@gmail.com>2015-03-25 05:56:36 -0400
commit5c0bc0050ccfd579ed75be384e928e0165d6b2ce (patch)
tree7bce2200f19b05448cb719b54037a7c2c82d6bab /CMakeLists.txt
parentMerges #36 (diff)
parentMerge pull request #243 (diff)
downloadmonero-5c0bc0050ccfd579ed75be384e928e0165d6b2ce.tar.xz
Merge upstream updates into blockchain branch
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b1b004189..f2b553d92 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -277,12 +277,18 @@ if (BOOST_IGNORE_SYSTEM_PATHS)
set(Boost_NO_SYSTEM_PATHS TRUE)
endif()
+set(OLD_LIB_SUFFIXES ${CMAKE_FIND_LIBRARY_SUFFIXES})
if(STATIC)
+ if(MINGW)
+ set(CMAKE_FIND_LIBRARY_SUFFIXES .a)
+ endif()
+
set(Boost_USE_STATIC_LIBS ON)
set(Boost_USE_STATIC_RUNTIME ON)
endif()
find_package(Boost 1.53 QUIET REQUIRED COMPONENTS system filesystem thread date_time chrono regex serialization program_options)
+set(CMAKE_FIND_LIBRARY_SUFFIXES ${OLD_LIB_SUFFIXES})
if(NOT Boost_FOUND)
die("Could not find Boost libraries, please make sure you have installed Boost or libboost-all-dev (1.53 or 1.55+) or the equivalent")
endif()