aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorredfish <redfish@galactica.pw>2016-09-17 14:31:25 -0400
committerredfish <redfish@galactica.pw>2016-09-17 15:36:15 -0400
commitc79104086c578738225182207c2fd5e17b9c5e6f (patch)
treeae39fc336aa0f6a23bf1d45340718b4c288f7145 /CMakeLists.txt
parentMerge pull request #1084 (diff)
downloadmonero-c79104086c578738225182207c2fd5e17b9c5e6f.tar.xz
cmake: quotes around ARCH_ID string
It's only blank only if somebody running cmake in MSYS/MinGW (Windows) manually forgets to add -D ARCH, but when it is blank, without quotes those lines are invalid cmake syntax.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0c813b867..ca600935d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -63,11 +63,11 @@ if (NOT ARCH OR ARCH STREQUAL "" OR ARCH STREQUAL "native" OR ARCH STREQUAL "def
else()
set(ARCH_ID "${ARCH}")
endif()
-string(TOLOWER ${ARCH_ID} ARM_ID)
-string(SUBSTRING ${ARCH_ID} 0 3 ARM_TEST)
+string(TOLOWER "${ARCH_ID}" ARM_ID)
+string(SUBSTRING "${ARCH_ID}" 0 3 ARM_TEST)
if (ARM_TEST STREQUAL "arm")
set(ARM 1)
- string(SUBSTRING ${ARCH_ID} 0 5 ARM_TEST)
+ string(SUBSTRING "${ARCH_ID}" 0 5 ARM_TEST)
if (ARM_TEST STREQUAL "armv6")
set(ARM6 1)
endif()