aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOracionSeis <this is my e-mail>2014-05-22 15:00:48 +0400
committerOracionSeis <this is my e-mail>2014-05-22 17:12:33 +0400
commit9f1ffe0473d247ac95764268baac6d0e1390b068 (patch)
tree96f69897008bddb39652eb4459a567e87fa10916 /CMakeLists.txt
parentUpdate CMakeLists.txt (diff)
downloadmonero-9f1ffe0473d247ac95764268baac6d0e1390b068.tar.xz
OS X compilation fixed
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3d367b2e1..e1c2586c5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -69,7 +69,11 @@ else()
else()
set(DEBUG_FLAGS "-g3 -O0")
endif()
- set(RELEASE_FLAGS "-Ofast -DNDEBUG -Wno-unused-variable -flto")
+ set(RELEASE_FLAGS "-Ofast -DNDEBUG -Wno-unused-variable")
+ if(NOT APPLE)
+ # There is a clang bug that does not allow to compile code that uses AES-NI intrinsics if -flto is enabled
+ set(RELEASE_FLAGS "${RELEASE_FLAGS} -flto")
+ endif()
#if(CMAKE_C_COMPILER_ID STREQUAL "GNU" AND NOT MINGW)
# set(RELEASE_FLAGS "${RELEASE_FLAGS} -fno-fat-lto-objects")
#endif()