aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorhyc <hyc@symas.com>2017-09-20 01:38:43 +0100
committerhyc <hyc@symas.com>2017-09-20 01:38:43 +0100
commit8b1acc9a8642c9e524307576f1e3586645b3b70c (patch)
treea485e83137eae81fa2f00d85d93a595debb2547f /CMakeLists.txt
parentMerge pull request #2446 (diff)
downloadmonero-8b1acc9a8642c9e524307576f1e3586645b3b70c.tar.xz
Fix OpenSSL 1.1 detection for static builds
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 971c097ff..49b256edb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -319,6 +319,12 @@ else()
message(STATUS "Stack trace on exception disabled")
endif()
+if (UNIX AND NOT APPLE)
+ # Note that at the time of this writing the -Wstrict-prototypes flag added below will make this fail
+ set(THREADS_PREFER_PTHREAD_FLAG ON)
+ find_package(Threads)
+endif()
+
# Handle OpenSSL, used for sha256sum on binary updates
if (APPLE AND NOT IOS)
if (NOT OpenSSL_DIR)
@@ -332,16 +338,10 @@ endif()
find_package(OpenSSL REQUIRED)
if(STATIC AND NOT IOS)
if(UNIX)
- set(OPENSSL_LIBRARIES "${OPENSSL_LIBRARIES};${CMAKE_DL_LIBS}")
+ set(OPENSSL_LIBRARIES "${OPENSSL_LIBRARIES};${CMAKE_DL_LIBS};${CMAKE_THREAD_LIBS_INIT}")
endif()
endif()
-if (UNIX AND NOT APPLE)
- # Note that at the time of this writing the -Wstrict-prototypes flag added below will make this fail
- set(THREADS_PREFER_PTHREAD_FLAG ON)
- find_package(Threads)
-endif()
-
add_definitions(-DAUTO_INITIALIZE_EASYLOGGINGPP)
add_subdirectory(external)