aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorredfish <redfish@galactica.pw>2016-09-03 14:11:26 +0200
committerredfish <redfish@galactica.pw>2016-09-03 12:55:20 -0400
commit77fa663e94fe9129f318dd76d53ffa627581f0fa (patch)
treefaf205f5087b852893e56762423f7c63d3eb62e9 /CMakeLists.txt
parentMerge pull request #1038 (diff)
downloadmonero-77fa663e94fe9129f318dd76d53ffa627581f0fa.tar.xz
cmake: split BUILD_GUI_DEPS option into two
The split is to make this software more packageable. 'make install' is used by the package building scripts, and should not be installing vendored dependencies onto the system.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 91f0ca1fb..c9aaafedc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -603,7 +603,11 @@ if(BUILD_DOCUMENTATION)
endif()
endif()
-# when ON - will install libunbound and libwallet_merged into "lib"
+# when ON - will install libwallet_merged into "lib"
option(BUILD_GUI_DEPS "Build GUI dependencies." OFF)
+# This is not nice, distribution packagers should not enable this, but depend
+# on libunbound shipped with their distribution instead
+option(INSTALL_VENDORED_LIBUNBOUND "Install libunbound binary built from source vendored with this repo." OFF)
+