aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormj-xmr <mjxmr@protonmail.com>2020-05-04 09:46:31 +0200
committermj-xmr <mjxmr@protonmail.com>2020-05-04 09:46:31 +0200
commit3843a6aba5a386554da5f301862270f8decc39dc (patch)
treeeac9aea233f8e88e2d8863f0a8595607121f413b /CMakeLists.txt
parentMerge pull request #6451 (diff)
downloadmonero-3843a6aba5a386554da5f301862270f8decc39dc.tar.xz
Made ccache optional (opt out) and tidied up the FindCcache.cmake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d9ec866e4..59c0aa21b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -48,7 +48,12 @@ message(STATUS "CMake version ${CMAKE_VERSION}")
project(monero)
-include(FindCcache) # Has to be included after the project() macro, to be able to read the CXX variable.
+option (USE_CCACHE "Use ccache if a usable instance is found" ON)
+if (USE_CCACHE)
+ include(FindCcache) # Has to be included after the project() macro, to be able to read the CXX variable.
+else()
+ message(STATUS "ccache deselected")
+endif()
enable_language(C ASM)