aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Boeckel <ben.boeckel@kitware.com>2014-11-17 18:10:52 -0500
committerBen Boeckel <ben.boeckel@kitware.com>2014-11-17 18:19:54 -0500
commit18c56abe4bf5d069abe9ee44442cbbb859f845f5 (patch)
treec4fcbd9e2323b43023b3f2a84740d7ba4fabdbe0 /CMakeLists.txt
parentmsys: factor out -Werror on msys (diff)
downloadmonero-18c56abe4bf5d069abe9ee44442cbbb859f845f5.tar.xz
msys: don't use LTO
This causes duplicate symbol errors on msys' mingw install.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 43d03a879..f3b517a8b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -158,6 +158,8 @@ else()
set(MINGW_FLAG "${MINGW_FLAG} -DWIN32_LEAN_AND_MEAN")
set(Boost_THREADAPI win32)
include_directories(SYSTEM src/platform/mingw)
+ # mingw doesn't support LTO (multiple definition errors at link time)
+ set(USE_LTO_DEFAULT false)
endif()
set(C_WARNINGS "-Waggregate-return -Wnested-externs -Wold-style-definition -Wstrict-prototypes")
set(CXX_WARNINGS "-Wno-reorder -Wno-missing-field-initializers")