aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2018-11-17 13:15:03 +0000
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2018-11-17 13:15:03 +0000
commit707c2f836b3136bc88b5aed374a4b3128f9596a7 (patch)
tree79979570b1911edfdd334be6d8ee671e60343701 /CMakeLists.txt
parentMerge pull request #4820 (diff)
downloadmonero-707c2f836b3136bc88b5aed374a4b3128f9596a7.tar.xz
Remove -Werror
It is an annoying piece of garbage
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0c38c673a..88a9b8834 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -599,9 +599,6 @@ else()
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${ARCH_FLAG}")
set(WARNINGS "-Wall -Wextra -Wpointer-arith -Wundef -Wvla -Wwrite-strings -Wno-error=extra -Wno-error=deprecated-declarations -Wno-unused-parameter -Wno-unused-variable -Wno-error=unused-variable -Wno-error=undef -Wno-error=uninitialized")
- if(NOT MINGW)
- set(WARNINGS_AS_ERRORS_FLAG "-Werror")
- endif()
if(CMAKE_C_COMPILER_ID STREQUAL "Clang")
if(ARM)
set(WARNINGS "${WARNINGS} -Wno-error=inline-asm")