aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2018-11-12 22:35:21 +0000
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2018-11-12 22:35:21 +0000
commit37d5b8d9c2fa9af258e6dc429544b95342b7dbf4 (patch)
treeea1ee251c0739f4526aa67f79506656cb054e673 /CMakeLists.txt
parentMerge pull request #4814 (diff)
downloadmonero-37d5b8d9c2fa9af258e6dc429544b95342b7dbf4.tar.xz
CMakeLists.txt: add -ftemplate-depth=900
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 388eee3fb..69177c85f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -816,6 +816,9 @@ else()
set(DEBUG_FLAGS "${DEBUG_FLAGS} -O0 ")
endif()
+ # At least some CLANGs default to not enough for monero
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -ftemplate-depth=900")
+
if(NOT DEFINED USE_LTO_DEFAULT)
set(USE_LTO_DEFAULT false)
endif()