aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoranon <anon [at] nowhere>2021-04-27 12:06:42 +0000
committerselsta <selsta@sent.at>2021-07-13 08:00:20 +0200
commitfe76d7dee7c8ddd7bb6d32cfc7aeedda9d84572e (patch)
treef3eb43648ff242c00842dcba516aa2c5c43fcabc /CMakeLists.txt
parentcmake: forbid undefined symbols (diff)
downloadmonero-fe76d7dee7c8ddd7bb6d32cfc7aeedda9d84572e.tar.xz
cmake: fix undefined symbols and multiple definitions
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3d59ab53d..9a932d28e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -572,6 +572,10 @@ if(STATIC AND NOT IOS)
endif()
endif()
+if (WIN32)
+ list(APPEND OPENSSL_LIBRARIES ws2_32 crypt32)
+endif()
+
find_package(HIDAPI)
add_definition_if_library_exists(c memset_s "string.h" HAVE_MEMSET_S)