aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorwoodser <woodser@protonmail.com>2020-12-04 11:48:41 -0500
committerwoodser <woodser@protonmail.com>2020-12-04 11:48:41 -0500
commit90246223c9dd2d729ae92c91d17d7b208c74d530 (patch)
treec2d2b899404c4db0cb31ba05f4cebe1c020c47c6 /CMakeLists.txt
parentMerge pull request #7058 (diff)
downloadmonero-90246223c9dd2d729ae92c91d17d7b208c74d530.tar.xz
add -framework AppKit for Apple
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 050269218..9963b4eb6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -952,10 +952,12 @@ list(APPEND EXTRA_LIBRARIES ${CMAKE_DL_LIBS})
if (HIDAPI_FOUND OR LibUSB_COMPILE_TEST_PASSED)
if (APPLE)
if(DEPENDS)
- list(APPEND EXTRA_LIBRARIES "-framework Foundation -framework IOKit")
+ list(APPEND EXTRA_LIBRARIES "-framework Foundation -framework AppKit -framework IOKit")
else()
find_library(COREFOUNDATION CoreFoundation)
+ find_library(APPKIT AppKit)
find_library(IOKIT IOKit)
+ list(APPEND EXTRA_LIBRARIES ${APPKIT})
list(APPEND EXTRA_LIBRARIES ${IOKIT})
list(APPEND EXTRA_LIBRARIES ${COREFOUNDATION})
endif()