aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorredfish <redfish@galactica.pw>2016-07-26 02:30:59 +0000
committerredfish <redfish@galactica.pw>2016-07-26 02:30:59 +0000
commit4b3a7885ac0ecbcf399c7784162751aadd0c90ea (patch)
tree6a0239c04b6ef4c7a95f4b4b48cb229f21418293 /CMakeLists.txt
parentcmake: do not install hook on throw when building tests (diff)
downloadmonero-4b3a7885ac0ecbcf399c7784162751aadd0c90ea.tar.xz
cmake: install throw hook in OSX build too
This is an attempt to fix build with STATIC=ON on OSX (#932): [ 95%] Linking CXX executable ../../bin/bitmonerod Undefined symbols for architecture x86_64: "___real___cxa_throw", referenced from: ___wrap___cxa_throw in libcommon.a(stack_trace.cpp.o) ld: symbol(s) not found for architecture x86_64
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6783b5002..0a0e75119 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -423,6 +423,9 @@ else()
if(STATIC AND NOT APPLE AND NOT FREEBSD AND NOT OPENBSD)
set(COMMON_EXE_LINKER_FLAGS "${COMMON_EXE_LINKER_FLAGS} -static-libgcc -static-libstdc++")
+ endif()
+
+ if(STATIC AND NOT FREEBSD AND NOT OPENBSD)
# Install hook on throw for dumping stack on exception (implemented in libcommon)
set(WRAP_CXA_THROW_FLAG "-Wl,--wrap=__cxa_throw")
endif()