aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoranon <anon [at] nowhere>2021-06-28 19:13:02 +0000
committerj-berman <justinberman@protonmail.com>2022-07-05 22:33:34 -0700
commit3be1dbd0963a76a05fd7f72f28100726daa1c4e7 (patch)
tree898384944e70933021d68620bfff60e0b55d3499 /CMakeLists.txt
parentconnection: add segfault and deadlocks demo (diff)
downloadmonero-3be1dbd0963a76a05fd7f72f28100726daa1c4e7.tar.xz
connection: fix implementation
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3abd0722a..b05c087cf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1076,6 +1076,7 @@ if(STATIC)
set(Boost_USE_STATIC_RUNTIME ON)
endif()
find_package(Boost 1.58 QUIET REQUIRED COMPONENTS system filesystem thread date_time chrono regex serialization program_options locale)
+add_definitions(-DBOOST_ASIO_ENABLE_SEQUENTIAL_STRAND_ALLOCATION)
set(CMAKE_FIND_LIBRARY_SUFFIXES ${OLD_LIB_SUFFIXES})
if(NOT Boost_FOUND)