aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorerciccione <erciccione@users.noreply.github.com>2019-04-20 14:59:31 +0200
committererciccione <erciccione@users.noreply.github.com>2019-04-20 15:26:05 +0200
commit2e514b8faa6fb4cabc6926e00e5d55a1d785b038 (patch)
tree421476d5ad5933068d657e65be21faaa6d16d972 /CMakeLists.txt
parentMerge pull request #5466 (diff)
downloadmonero-2e514b8faa6fb4cabc6926e00e5d55a1d785b038.tar.xz
CMakeLists.txt: suggest to update all submodules if one of them is outdated
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c19c9dba7..f65accbc3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -187,7 +187,7 @@ if(NOT MANUAL_SUBMODULES)
if (upToDate)
message(STATUS "Submodule '${relative_path}' is up-to-date")
else()
- message(FATAL_ERROR "Submodule '${relative_path}' is not up-to-date. Please update with\ngit submodule update --init --force ${relative_path}\nor run cmake with -DMANUAL_SUBMODULES=1")
+ message(FATAL_ERROR "Submodule '${relative_path}' is not up-to-date. Please update all submodules with\ngit submodule update --init --force\nor run cmake with -DMANUAL_SUBMODULES=1\n")
endif()
endfunction ()