aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorluigi1111 <luigi1111w@gmail.com>2018-06-08 14:34:01 -0500
committerluigi1111 <luigi1111w@gmail.com>2018-06-08 14:34:01 -0500
commit112f3678bc02031baeafad41310f932e92bff579 (patch)
tree477e895e608ecad33fd9fa25433a7a911d23d5c7 /CMakeLists.txt
parentMerge pull request #3450 (diff)
parentIncorporate Window debug build targets (diff)
downloadmonero-112f3678bc02031baeafad41310f932e92bff579.tar.xz
Merge pull request #3887
14f0d38 Incorporate Window debug build targets (philkode)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e3cfaa24b..73c5f6e93 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -791,6 +791,7 @@ endif()
include_directories(SYSTEM ${Boost_INCLUDE_DIRS})
if(MINGW)
+ set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -Wa,-mbig-obj")
set(EXTRA_LIBRARIES mswsock;ws2_32;iphlpapi)
set(ICU_LIBRARIES ${Boost_LOCALE_LIBRARY} icuio icuin icuuc icudt icutu iconv)
elseif(APPLE OR OPENBSD OR ANDROID)