aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNanoAkron <nanoakron@users.noreply.github.com>2017-01-09 13:38:54 +0000
committerNanoAkron <nanoakron@users.noreply.github.com>2017-01-09 16:39:44 +0000
commite68ea86cc4e255154686bc9145a2e1bd8546a7c9 (patch)
tree0b0cb727cfc02b5b1af7952b8ff2ee52a168756a /CMakeLists.txt
parentMerge pull request #1542 (diff)
downloadmonero-e68ea86cc4e255154686bc9145a2e1bd8546a7c9.tar.xz
Change logic of testing for libunwind on OSX and ARM
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 9 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e42cdb384..eea161bdb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -273,14 +273,19 @@ endif()
add_definitions("-DBLOCKCHAIN_DB=${BLOCKCHAIN_DB}")
-find_package(Libunwind)
# Can't install hook in static build on OSX, because OSX linker does not support --wrap
# On ARM, having libunwind package (with .so's only) installed breaks static link.
-if(LIBUNWIND_FOUND AND NOT (STATIC AND (APPLE OR ARM)))
- set(DEFAULT_STACK_TRACE ON)
-else()
+if(APPLE OR (ARM AND STATIC))
set(DEFAULT_STACK_TRACE OFF)
set(LIBUNWIND_LIBRARIES "")
+else()
+ find_package(Libunwind)
+ if(LIBUNWIND_FOUND)
+ set(DEFAULT_STACK_TRACE ON)
+ else()
+ set(DEFAULT_STACK_TRACE OFF)
+ set(LIBUNWIND_LIBRARIES "")
+ endif()
endif()
option(STACK_TRACE "Install a hook that dumps stack on exception" ${DEFAULT_STACK_TRACE})