aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas Winget <tewinget@gmail.com>2015-03-16 03:12:54 -0400
committerThomas Winget <tewinget@gmail.com>2015-03-16 04:17:53 -0400
commitcade0da8f1e932a17886aa9893a580fa3e3289c7 (patch)
treebbb2c171f01b37e227754d648e29c93f15bb344b /CMakeLists.txt
parentBerkeleyDB BlockchainDB impl copy/paste/modify (diff)
downloadmonero-cade0da8f1e932a17886aa9893a580fa3e3289c7.tar.xz
CMake wiring, minor cleanup, minor test addition
Make Cmake things aware of BerkeleyDB and BlockchainBDB Make the BlockchainDB unit tests aware of BlockchainBDB
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2916ff137..9e29dab59 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -162,6 +162,9 @@ include_directories(external/rapidjson)
# Final setup for liblmdb
include_directories(${LMDB_INCLUDE})
+# Final setup for Berkeley DB
+include_directories(${BDB_INCLUDE})
+
if(MSVC)
add_definitions("/bigobj /MP /W3 /GS- /D_CRT_SECURE_NO_WARNINGS /wd4996 /wd4345 /D_WIN32_WINNT=0x0600 /DWIN32_LEAN_AND_MEAN /DGTEST_HAS_TR1_TUPLE=0 /FIinline_c.h /D__SSE4_1__")
# set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} /Dinline=__inline")