aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-06-27 17:06:01 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-06-27 17:06:19 +0000
commit44bfe6048b469746e9095c08b66529eafb9f1066 (patch)
tree0b9fe766370ebd831016b885191a2a9404c7fb0e /CMakeLists.txt
parentMerge pull request #2111 (diff)
downloadmonero-44bfe6048b469746e9095c08b66529eafb9f1066.tar.xz
enable monero build on ppc64le architecture
Fix wrong flags for ppc64le: -maes - not avaiable -march - changed by -mcpu that does the same for powerpc
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a8060f90c..45745abee 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -86,6 +86,10 @@ if (ARM_ID STREQUAL "aarch64" OR ARM_ID STREQUAL "arm64" OR ARM_ID STREQUAL "arm
set(ARCH "armv8-a")
endif()
+if(ARCH_ID STREQUAL "ppc64le")
+ set(PPC64LE 1)
+endif()
+
if(WIN32 OR ARM)
set(OPT_FLAGS_RELEASE "-O2")
else()
@@ -386,6 +390,8 @@ else()
message(STATUS "Building on ${CMAKE_SYSTEM_PROCESSOR} for ${ARCH}")
if(ARCH STREQUAL "default")
set(ARCH_FLAG "")
+ elseif(PPC64LE)
+ set(ARCH_FLAG "-mcpu=${ARCH}")
else()
set(ARCH_FLAG "-march=${ARCH}")
endif()
@@ -442,10 +448,12 @@ else()
option(NO_AES "Explicitly disable AES support" ${NO_AES})
- if(NOT NO_AES AND NOT ARM)
+ if(NOT NO_AES AND NOT ARM AND NOT PPC64LE)
message(STATUS "AES support enabled")
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -maes")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -maes")
+ elseif(PPC64LE)
+ message(STATUS "AES support not available on ppc64le")
elseif(ARM6)
message(STATUS "AES support not available on ARMv6")
elseif(ARM7)