aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorluigi1111 <luigi1111w@gmail.com>2018-09-04 18:12:52 -0500
committerluigi1111 <luigi1111w@gmail.com>2018-09-04 18:12:52 -0500
commitfad88e18a9795b377676ad6f63c1772868e0d761 (patch)
treeeb271449a4e0320ed3eb24605f5cda4a9afbdeef /CMakeLists.txt
parentMerge pull request #4271 (diff)
parentCMakeLists.txt: disable -fstack-protector* on windows (diff)
downloadmonero-fad88e18a9795b377676ad6f63c1772868e0d761.tar.xz
Merge pull request #4290
2bc977b CMakeLists.txt: disable -fstack-protector* on windows
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8f2bdc78a..a02f62e62 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -563,10 +563,12 @@ else()
add_cxx_flag_if_supported(-Wformat-security CXX_SECURITY_FLAGS)
# -fstack-protector
- add_c_flag_if_supported(-fstack-protector C_SECURITY_FLAGS)
- add_cxx_flag_if_supported(-fstack-protector CXX_SECURITY_FLAGS)
- add_c_flag_if_supported(-fstack-protector-strong C_SECURITY_FLAGS)
- add_cxx_flag_if_supported(-fstack-protector-strong CXX_SECURITY_FLAGS)
+ if (NOT WIN32)
+ add_c_flag_if_supported(-fstack-protector C_SECURITY_FLAGS)
+ add_cxx_flag_if_supported(-fstack-protector CXX_SECURITY_FLAGS)
+ add_c_flag_if_supported(-fstack-protector-strong C_SECURITY_FLAGS)
+ add_cxx_flag_if_supported(-fstack-protector-strong CXX_SECURITY_FLAGS)
+ endif()
# linker
if (NOT WIN32)