aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorphilkode <philkode@protonmail.com>2018-05-31 10:40:00 +0100
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2018-05-31 10:49:24 +0100
commit14f0d38cd6b5ea7329180c73da5f497bee6eb5f0 (patch)
tree0a183ae04017e0cd9380c093eb325237bf30e2ee /CMakeLists.txt
parentMerge pull request #3251 (diff)
downloadmonero-14f0d38cd6b5ea7329180c73da5f497bee6eb5f0.tar.xz
Incorporate Window debug build targets
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b1297e716..e6ced6ec4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -791,6 +791,7 @@ endif()
include_directories(SYSTEM ${Boost_INCLUDE_DIRS})
if(MINGW)
+ set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -Wa,-mbig-obj")
set(EXTRA_LIBRARIES mswsock;ws2_32;iphlpapi)
set(ICU_LIBRARIES ${Boost_LOCALE_LIBRARY} icuio icuin icuuc icudt icutu iconv)
elseif(APPLE OR OPENBSD OR ANDROID)