aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Blair <snipa@jagtech.io>2020-07-19 03:29:26 -0700
committerAlexander Blair <snipa@jagtech.io>2020-07-19 03:29:26 -0700
commit7cd0d7f324d90c0fab2576c6a3f7f80942560dcf (patch)
tree19d8ed7b01535faa5faa82b95cd19dd5d277a9ee /CMakeLists.txt
parentMerge pull request #6497 (diff)
parentMade ccache optional (opt out) and tidied up the FindCcache.cmake (diff)
downloadmonero-7cd0d7f324d90c0fab2576c6a3f7f80942560dcf.tar.xz
Merge pull request #6501
3843a6ab Made ccache optional (opt out) and tidied up the FindCcache.cmake (mj-xmr)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 45a6aa1b5..1885dee67 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -48,7 +48,12 @@ message(STATUS "CMake version ${CMAKE_VERSION}")
project(monero)
-include(FindCcache) # Has to be included after the project() macro, to be able to read the CXX variable.
+option (USE_CCACHE "Use ccache if a usable instance is found" ON)
+if (USE_CCACHE)
+ include(FindCcache) # Has to be included after the project() macro, to be able to read the CXX variable.
+else()
+ message(STATUS "ccache deselected")
+endif()
enable_language(C ASM)