aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2019-05-30 12:11:58 +0000
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2019-05-30 19:38:02 +0000
commitcb92d5cb2cdb28ecd614fbd79c023855d7336f9a (patch)
tree7f6594e4f6fdb450350bcd27a449c02fe5cd5c09 /CMakeLists.txt
parentMerge pull request #5548 (diff)
downloadmonero-cb92d5cb2cdb28ecd614fbd79c023855d7336f9a.tar.xz
cmake: push cmake away from boost as much as we can
Everything works better without cmake.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 037b9cb50..25ead12a3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -875,10 +875,10 @@ if (${BOOST_IGNORE_SYSTEM_PATHS} STREQUAL "ON")
endif()
set(OLD_LIB_SUFFIXES ${CMAKE_FIND_LIBRARY_SUFFIXES})
+set(Boost_NO_BOOST_CMAKE ON)
if(STATIC)
if(MINGW)
set(CMAKE_FIND_LIBRARY_SUFFIXES .a)
- set(Boost_NO_BOOST_CMAKE ON)
endif()
set(Boost_USE_STATIC_LIBS ON)